MediaWiki < 1.19.10 / 1.21.4 / 1.22.1 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains an application that is affected by
multiple vulnerabilities.

Description :

According to its version number, the instance of MediaWiki installed
on the remote host is affected by the following vulnerabilities :

- Escape sequences are not properly sanitized when passed
to the 'Sanitizer::checkCss' class, which could result
in cross-site scripting attacks. (CVE-2013-6451)

- An input validation error exists in the
'XmlTypeCheck.php' script in uploaded SVG files that
contain external stylesheets, which could lead to
cross-site scripting attacks. (CVE-2013-6452)

- Input validation by the 'checkSvgScriptCallback'
function is bypassed in the 'UploadBase.php' script
when an SVG file with invalid XML is uploaded. This
could result in malicious code execution.
(CVE-2013-6453)

- An input validation error exists in the 'Sanitizer.php'
script when input is submitted to the '-o-link'
attribute, which could for allow cross-site scripting
attacks in Opera 12. (CVE-2013-6454)

- An information disclosure vulnerability exists in the
log API, Enhanced Recent Changes feature, and users'
watchlists that could allow deleted log entries to be
viewed. (CVE-2013-6472)

Additionally, the following extensions contain vulnerabilities, but
are not enabled or installed by default, unless otherwise noted.

- The TimedMediaHandler extension is affected by a
cross-site scripting vulnerability due to the lack of
input validation of the 'data-videopayload' attribute
in the 'mw.PopUpThumbVideo.js' script. (CVE-2013-4574)

- The Scribuntu extension is affected by a NULL pointer
dereference and buffer overflow flaw in the
implementation of the 'luasandbox' PHP extension that
could lead to a denial of service or arbitrary code
execution. (CVE-2013-4570, CVE-2013-4571)

- The CentralAuth extension is affected by an information
disclosure vulnerability due to the insertion of a
username into the page's DOM. (CVE-2013-6455)

- The Semantic Forms extension is affected by a cross-site
request forgery (CSRF) vulnerability due to the lack of
token validation in the 'Special:CreateCategory' page.
(CVE-2014-3454)

Note that Nessus has not tested for these issues but has instead
relied on the application's self-reported version number.

See also :

http://www.nessus.org/u?4c1aad04
https://www.mediawiki.org/wiki/Release_notes/1.19#MediaWiki_1.19.10
https://www.mediawiki.org/wiki/Release_notes/1.20#MediaWiki_1.21.4
https://www.mediawiki.org/wiki/Release_notes/1.21#MediaWiki_1.22.1

Solution :

Upgrade to MediaWiki version 1.19.10 / 1.21.4 / 1.22.1 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true