Apache Subversion 1.8.x < 1.8.2 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by multiple
vulnerabilities.

Description :

The version of Subversion Server installed on the remote host is prior
to version 1.8.2. It is, therefore, affected by multiple
vulnerabilities :

- A repository corruption vulnerability related to
'FileSystem atop the FileSystem' (FSFS) repositories
and handling packed revision properties editing.
(CVE-2013-4246)

- A symlink privilege escalation vulnerability in
'svnwcsub.py' and 'irkerbridge.py' exists when the
--pidfile option is used. The option creates temporary
files insecurely, and may allow a local attacker to use
a symlink attack against a pid file to gain elevated
privileges. (CVE-2013-7393)

See also :

http://subversion.apache.org/security/CVE-2013-4246-advisory.txt
https://subversion.apache.org/security/CVE-2013-4262-advisory.txt
http://svn.haxx.se/dev/archive-2013-08/0329.shtml

Solution :

Upgrade to Subversion Server 1.8.3 or later, or apply the vendor patch
or workaround.

Note that version 1.8.2 was not publicly released, and thus version
1.8.3 is the recommended version.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 71567 ()

Bugtraq ID: 62266
68966

CVE ID: CVE-2013-4246
CVE-2013-7393