Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MantisBT 1.2.x < 1.2.20 / 1.3.x < 1.3.0-rc.2 XSS

Medium

Synopsis

The remote web server is hosting an outdated web application that is vulnerable to an information disclosure attack reflected cross-site scripting (XSS) attack vector.

Description

Versions of MantisBT 1.2.x prior to 1.2.20 or 1.3.x prior to 1.3.0-rc.2 are affected by a flaw that allows a XSS attack. This flaw exists because the 'manage_custom_field_edit_page.php' script does not validate input to the 'return' parameter before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to MantisBT 1.3.0-rc.2 or later. If 1.3.x cannot be obtained, version 1.2.20 has also been patched.