Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle 2.7.x < 2.7.15 Remote Header Email Address Injection

Medium

Synopsis

The remote web server is hosting a web application that is vulnerable to a remote header injection attack vector.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.7.x prior to 2.7.15 are affected by a flaw that may allow an authenticated remote attacker to inject email addresses into the intended recipients of an email by changing their username to include another user's email address. This may result in other users potentially being saturated with emails. (CVE-2016-5013)

Solution

Upgrade to Moodle version 2.7.15 or later.