Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle 2.4.x < 2.4.8 / 2.5.x < 2.5.4 / 2.6.x < 2.6.1 Multiple Vulnerabilities



The remote web server is hosting a web application that is vulnerable to multiple attack vectors.


The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.4.x prior to 2.4.8, 2.5.x prior to 2.5.4 or 2.6.x prior to 2.6.1 are exposed to the following vulnerabilities :

- A flaw exists that is due to the program recording some users' passwords and exposing them in plaintext in the config log report. This may allow an authenticated remote attacker to gain access to password information. (CVE-2014-0008) - A flaw exists that is due to the program failing to apply group constraints when handling a request from a specially crafted URL. This may allow a remote attacker to bypass authentication and login as a user outside of the groups in which they are authorized to do so. (CVE-2014-0009) - A flaw exists as HTTP requests to 'user/profile/index.php' do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to delete custom user profile fields and categories. (CVE-2014-0010)


Upgrade to Moodle version 2.6.1 or later. If version 2.6.x cannot be obtained, versions 2.5.4, and 2.4.8 are also patched for these issues.