Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.5.x < 4.5.5.1 Multiple Vulnerabilities (PMASA-2016-10, PMASA-2016-13)

Medium

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.5.x prior to 4.5.5.1 are unpatched for the following vulnerabilities :

- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the SQL query page does not validate input when handling a crafted SQL query before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2016-2559) - An unspecified flaw exists within the API call to Github that may allow a remote attacker to perform a man-in-the-middle attack. No further details have been provided. (CVE-2016-2562)

Solution

Upgrade to phpMyAdmin 4.5.5.1 or later. Alternatively, apply the patch referenced in the vendor advisory.