Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

OpenSSH < 7.1 PermitRootLogin Bypass Vulnerability

Low

Synopsis

The remote SSH server may be affected by a restriction bypass vulnerability.

Description

OpenSSH contains a logic error in 'PermitRootLogin=' prohibit-password/without-password that is triggered when certain compile-time configurations are used allowing authentication to occur over SSH when it should not be, though the attacker would still require knowledge of valid credentials.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH version 7.1 or later.