Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

OpenSSH < 6.9 Multiple Vulnerabilities

High

Synopsis

The remote SSH server may be affected by multiple vulnerabilities.

Description

Versions of OpenSSH server before 6.9 are affected by the following vulnerabilities :

- A flaw within the 'x11_open_helper()' function in the 'channels.c' file that allows connections to be permitted after 'ForwardX11Timeout' has expired. A remote attacker can exploit this to bypass timeout checks and XSECURITY restrictions. (CVE-2015-5352) - Various issues were addressed by fixing the weakness in agent locking by increasing the failure delay, storing the salted hash of the password, and using a timing-safe comparison function. - An out-of-bounds read error exists when handling incorrect pattern lengths. A remote attacker can exploit this to cause a denial of service or disclose sensitive information in the memory. (OSVDB 124019) - An out-of-bounds read error exists when parsing the 'EscapeChar' configuration option.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH version 6.9 or later.