Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Bugzilla 2.0 < 4.2.15 / 4.3.1 < 4.4.10 / 4.5.1 < 5.0.1 Unauthorized Account Creation Vulnerability

Medium

Synopsis

The remote web server contains a web application that is affected by a vulnerability that allows the creation of user accounts.

Description

According to its banner, the version of Bugzilla running on the remote host falls within the range of 2.0 prior to 4.2.15, 4.3.1 prior to 4.4.10, or 4.5.1 prior to 5.0.1. Such versions are affected by an account creation bug that causes input passed via the 'login' parameter to be truncated, resulting in domain names of email addresses becoming corrupted. An unauthenticated, remote attacker can exploit this to create accounts with email addresses that differ from the original requests.

Solution

Upgrade to versions 4.2.15, 4.4.10, 5.0.1, or later.