Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Zend Framework < 2.2.5 Trusted Proxy Bypass

Medium

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to a security bypass attack.

Description

Versions of Zend Framework prior to 2.2.5 are vulnerable to a flaw in the 'Zend\Http\PhpEnvironment\RemoteAddress' class. The issue is triggered when PHP's $_SERVER['REMOTE_ADDR'] is not taken into account on the trusted proxy server list when handling an incoming proxied request via the 'X-Forwarded-For' header. This may allow a remote attacker to bypass the trusted proxy list.

Solution

Upgrade Zend Framework to version 2.2.5 or later.