Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Zend Framework 1.12.x < 1.12.4 / 2.1.x < 2.1.6 / 2.2.x < 2.2.6 Multiple XEE DoS

High

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to multiple XEE vulnerabilities.

Description

Versions of Zend Framework 1.12.x earlier than 1.12.4, 2.1.x earlier than 2.1.6, or 2.2.x earlier than 2.2.6 are exposed to XEE (XML Entity Expansion) injection flaws that exist in multiple functions and are triggered during the parsing of XML data via DOCTYPE declarations. The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. By sending specially crafted XML data, a remote attacker can cause a denial of service.

Solution

Upgrade Zend Framework to version 2.2.6 or later. If version 2.2.x is not available, versions 2.1.6 and 1.12.4 are also patched for these vulnerabilities.