Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Zend Framework < 2.2.7 / 2.3.x < 2.3.1 XSS

Medium

Synopsis

The remote host is running a version of Zend Framework that is vulnerable to Cross-Site Scripting (XSS) attacks.

Description

Versions of Zend Framework earlier than 2.2.7, or 2.3.x earlier than 2.3.1 are vulnerable to a flaw that allows cross-site scripting (XSS) attacks. This flaw exists because multiple view helpers do not properly validate input to HTML attributes before returning it to users. This may allow an attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade Zend Framework to version 2.3.1 or later. If version 2.3.x is not available, version 2.2.7 is also patched for this vulnerability.