Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MyBB < 1.6.17 / 1.8.x < 1.8.5 Multiple Vulnerabilities

Medium

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

Versions of MyBB (MyBulletinBoard) prior to 1.6.17, or 1.8.x prior to 1.8.5 are affected by the following vulnerabilities :

- A validation flaw in the 'member.php' script that can allow a remote attacker to bypass the reset password code check and reset arbitrary passwords. (OSVDB 122738) - A flaw exists in ACP Mass Mail Cancellation feature as HTTP requests do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to mass cancel mails. (OSVDB 122739) - A flaw exists which allows users to create usernames with the 'U+200E' unicode characters. This may allow a remote attacker to create usernames that appear overly similar to another user's name. (OSVDB 122740) - An access flaw exists in 'search.php' that is due to the program failing to check for permissions when searching for posts with old SIDs. This may allow a remote attacker to gain access to potentially sensitive information in old posts. (OSVDB 122741)

Solution

Upgrade to MyBB version 1.6.17 / 1.8.5 or later.