Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache ActiveMQ 5.x < 5.11.2 Blob Message Directory Traversal

Medium

Synopsis

A web application on the remote host is affected by a directory traversal vulnerability.

Description

Versions 5.x.x of Apache ActiveMQ prior to 5.11.2 are affected by a directory traversal vulnerability due to improper sanitization of user-supplied input in the fileserver upload and download functionality. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to read and upload arbitrary JSP files, resulting in the execution of arbitrary commands.

Solution

Upgrade to ActiveMQ 5.11.2 or later.