Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

WordPress < 4.3.1 Multiple Vulnerabilities

Medium

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.

Description

Versions of WordPress prior to 4.3.1 are susceptible to the following vulnerabilities :

- A cross-site scripting vulnerability exists when processing shortcode tags due to improper validation of user-supplied input. An attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2015-5714) - A cross-site scripting (XSS) vulnerability affects the User List. This flaw exists because the program does not validate input to user list tables before returning it to users. (CVE-2015-7989) - An unspecified vulnerability exists that allows an authenticated attacker to publish private posts and make them 'sticky'. (CVE-2015-5715)

Solution

Upgrade to WordPress 4.3.1, or later.