Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

WordPress < 3.9.5 / 4.1.x < 4.1.4 / 4.2.x < 4.2.1 Comments Stored XSS

Medium

Synopsis

The remote server is hosting an outdated installation of WordPress that is affected by a cross-site scripting vulnerability.

Description

Versions of WordPress 3.9.x prior to 3.9.5 , 4.1.x prior to 4.1.4 , and 4.2.x prior to 4.2.1 are affected by an input validation flaw that allows an unauthenticated attacker to inject JavaScript into WordPress comments. This could result in a stored cross-site scripting attack being carried out when the affected comment is later viewed.

Solution

Upgrade to WordPress 4.2.1, or later. If 4.2.x cannot be obtained, 4.1.4 was also patched for this vulnerability.\n\nAs a workaround, disable comments and do not approve any comments.