Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MantisBT < 1.2.18 Multiple Vulnerabilities

High

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server is hosting MantisBT, an open source bug tracking application written in PHP.

Versions of MantisBT prior to 1.2.18 are affected by the following vulnerabilities :

- Multiple input validation errors exist that could allow cross-site scripting attacks. (CVE-2014-7146, CVE-2014-9271, CVE-2014-9280, CVE-2014-9281)

- An unspecified errors exist that could allow SQL injection attacks. (CVE-2014-9089)

- Two unspecified errors exist that could allow information disclosure attacks. (CVE-2014-8553, CVE-2014-8988)

- An error exists in the file 'gpc_api.php' that could allow an attacker to bypass authentication protections by using a password that starts with a NULL byte.(CVE-2014-6387)

- An error exists in the 'XML Import/Export' plugin that could allow unauthorized attackers to upload XML files or obtain sensitive information. (CVE-2014-8598)

- An error exists related to the CAPTCHA protection mechanism and the parameter 'public_key' that could allow security bypasses. (CVE-2014-9117)

Solution

Upgrade to MantisBT 1.2.18 or later.