Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle 2.5.x < 2.5.7 / 2.6.x < 2.6.4 / 2.7.x < 2.7.1 XSS

Medium

Synopsis

The remote web server hosts a PHP script that is affected by multiple cross-site scripting vulnerabilities.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.5.x prior to 2.5.8, 2.6.x prior to 2.6.5, and 2.7.x prior to 2.7.1 are vulnerable to multiple cross-site scripting (XSS) vulnerabilities that affect the script 'badges/renderer.php' because it fails to properly sanitize user-supplied badge details from external sources. An attacker can exploit these issues by crafting a badge which contains malicious code that will inject arbitrary HTML or script code in a users browser upon rendering the badge in their browser. (MSA-14-0028 / CVE-2014-3547)

Solution

Upgrade to Moodle version 2.7.1 or later. If your installation cannot be upgraded to 2.7.x, versions 2.6.4 and 2.5.7 are also patched for these vulnerabilities.