Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle 2.7.x < 2.7.3 Information Disclosure

Medium

Synopsis

The remote web server is hosting a web application that is vulnerable to an information disclosure vulnerability.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.7.x prior to 2.7.3 are exposed to an information disclosure flaw because it does not consider the 'moodle/grade:viewhidden' capability before displaying hidden grades, which allows remote authenticated users to obtain sensitive information by leveraging the student role to access the 'core_grades_get_grades' web service. Specifically, this affects the script 'lib/classes/grades_external.php'. (MSA-14-0038 / CVE-2014-7831)

Solution

Upgrade to Moodle version 2.8 or later. If 2.8.x cannot be obtained, 2.7.3 has also been patched for this vulnerability.