Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Revive Adserver < 3.1.0 Multiple Vulnerabilities

Medium

Synopsis

The remote host running Revive Adserver is prone to multiple vulnerabilities because it is hosting an outdated version.

Description

The remote host is running Revive Adserver, an open source PHP-based Ad serving system. This version of Revive Adserver is vulnerable to the following:

- A denial-of-service vulnerability that occurs in the 'XML-RPC' implementation. Specifically, the issue affects the 'XML/RPC.php' script. (CVE-2014-8875)

- A cross-site scripting vulnerability because Revive fails to properly sanitize user-supplied input. Specifically, this issue affects the 'refresh_page' parameter of the '/www/admin/report-generate.php' script. (CVE-2014-8793)

Solution

Upgrade to Revive Adserver 3.1.0 or later.