Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.0.x < 4.0.10.2 / 4.1.x < 4.1.14.3 / 4.2.x < 4.2.7.1 Multiple XSS (PMASA-2014-8, PMASA-2014-9)

Medium

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin earlier than 4.0.10.2, 4.1.14.3, or 4.2.7.1 are unpatched for cross-site scripting vulnerabilities on the following pages:

- The view operations page - browse table - ENUM editor - monitor - query charts and table relations pages

Note that these vulnerabilities may only be leveraged by a user who is logged in.

Solution

Either upgrade to phpMyAdmin 4.0.10.2, 4.1.14.3, 4.2.7.1 or later, or apply the patches from the referenced links.