Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Ecava IntegraXor < 3.6.4000.1 Directory Traversal

Medium

Synopsis

A vulnerable version of Ecava IntegraXor has been detected.

Description

IntegraXor versions prior to 3.6.4000.1 contain a flaw that allows a remote attacker to traverse outside of a restricted path. This issue is due to the 'open' script not properly sanitizing user input, specifically directory traversal style attacks (e.g., ../../) supplied via the 'file_name' parameter. Successful exploitation of this vulnerability would allow an attacker to read arbitrary files.

Solution

Upgrade to IntegraXor version 3.6.4000.1 or later.