Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

OpenSSH v6.2 / v6.3 Remote Memory Corruption Vulnerability



The remote SSH service may be affected by a memory corruption vulnerability that could allow an attacker to execute arbitrary code in the context of the authenticated user.


Versions of OpenSSH server before 6.4 may contain a memory corruption vulnerability that exists in the post-authentication 'sshd' process when an AES-GCM cipher is selected during key exchange. This issue can be exploited to execute arbitrary code with the privileges of an authenticated user and bypass restricted shell/command configurations.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.


Upgrade to OpenSSH version 6.4 or later.