Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Drupal OpenID module < 5.x-1.5 Authentication Bypass Vulnerability

High

Synopsis

The remote web server is hosting a web application that is affected by an authentication bypass vulnerability.

Description

The remote web server hosts a Drupal install that uses the OpenID module, a module that allows users to authenticate via OpenID.

Versions of Drupal OpenID module earlier than 5.x-1.5 are potentially affected by an authentication bypass vulnerability because the application fails to implement all the required verifications from the OpenID 2.0 protocol. A remote attacker, exploiting this flaw, could gain unauthorized access to the affected Drupal install.

Solution

Upgrade to Drupal OpenID module 5.x-1.5 or later.