Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

SquirrelMail < 1.4.21 Multiple Vulnerabilities

Medium

Synopsis

The remote web server if vulnerable to a denial-of-service attack.

Description

The remote host is running SquirrelMail, a web-based email client.

Versions of SquirrelMail earlier than 1.4.21 are potentially affected by a denial-of-service vulnerability. By submitting a random login with 8-bit characters in the password, it is possible to cause SquirrelMail to create a preferences file even if the login is not valid. An attacker, exploiting this flaw, could create enough files to cause the server to run out of disk space.

Solution

Upgrade to SquirrelMail 1.4.21 or later.