Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Simple Machines < 1.1.9 / 2.0.0 RC1 XSS (deprecated)

Medium

Synopsis

The remote host is vulnerable to a cross-site scripting attack.

Description

The remote host is running Simple Machines Forum. The installed version is earlier than 1.1.9 / 2.0.0 RC1-1. Such versions fail to properly sanitize user-supplied images identified as 'image/bmp' MIME types. Successful exploitation would result in an attacker executing script code within the browsers of other users.

Solution

Upgrade to Simple Machines Forum 1.1.9 / 2.0.0 RC1-1