Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Plesk Multiple Script PLESKSESSID Cookie SQL Injection

Medium

Synopsis

The remote host is vulnerable to a SQL injection attack.

Description

The remote host is running Plesk. Plesk is a web-based administrative console written in PHP. This version of Plesk is vulnerable to a flaw in the way that it handles the 'PLESKSESSID' cookie when passed via the 'login.php3' and 'auth.php3' scripts. An attacker exploiting this flaw would only need to be able to send HTTP requests to the vulnerable application. Successful exploitation would result in the attacker executing arbitrary SQL commands on the remote database server utilized by Plesk.

Solution

Upgrade to a version of Plesk other than 7.6.1, 8.1.0, 8.1.1 and 8.2.0.