Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP-Fusion < 6.00.107 Multiple Vulnerabilities

Medium

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

According to its version number, the remote host is running a version of PHP-Fusion that suffers from multiple vulnerabilities. Namely:

HTML Injection Vulnerability - An attacker can inject malicious CSS (Cascading Style Sheets) codes through [color] tags, thereby affecting how the site is rendered whenever users view specially-crafted posts.

SQL Injection Vulnerability - The application fails to sanitize user-supplied input to the 'msg_view' parameter of the 'messages.php' script before using it in database queries. Exploitation requires that an attacker first authenticate.

Solution

Upgrade to version 6.00.107 or higher.