Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpPgAdmin < 3.5.4 index.php formLanguage Parameter Traversal Arbitrary File Access

Medium

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is running phpPgAdmin, a web-based PostgreSQL administrative interface. This version of phpPgAdmin is vulnerable to a flaw via the Login form. Specifically, a malformed 'formLanguage' directive can be used to retrieve sensitive files (such as /etc/passwd or other critical configuration files).

Solution

Upgrade to version 3.5.4 or higher.