Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Invision Board Multiple XSS and SQL Injection

Medium

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running Invision Board, a CGI suite designed to set up a bulletin board system on the remote web server. This version of Invision Board is vulnerable to a Cross-Site Scripting (XSS) flaw where attackers can supply malicious script code to the 'act' parameter of the index.php script. An attacker exploiting this flaw would need to be able to convince a user to browse to a malicious URI. Successful exploitation would result in the theft of confidential materials (such as authentication cookies). In addition, the remote application is vulnerable to a remote SQL Injection attack. An attacker exploiting this flaw would send a malformed query to the application. The query would include reserved SQL characters and syntax. Successful exploitation would result in the loss of integrity and confidentiality.

Solution

Upgrade to version 2.0.4, 2.1.0 Alpha 3 or higher.