Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Pine < 4.58 Multiple Overflows

High

Synopsis

The remote host is vulnerable to an arbitrary 'command insertion' flaw.

Description

Pine versions 4.56 and below suffer from a vulnerability which allows an attacker to force the client to execute the attacker's code on the client's system. This issue is easily exploitable since the client will send it's version number by default allowing an attacker to easily identify potential targets.

Solution

Upgrade to Version 4.58 or higher