Rockwell Automation MicroLogix (CVE-2022-2179)

medium Tenable OT Security Plugin ID 500693

Synopsis

The remote OT asset is affected by a vulnerability.

Description

The X-Frame-Options header in Rockwell Automation MicroLogix 1100/1400 Versions 21.007 and prior is not configured in the HTTP response, which could allow clickjacking attacks.

This plugin only works with Tenable.ot.
Please visit https://www.tenable.com/products/tenable-ot for more information.

Solution

The following text was originally created by the Cybersecurity and Infrastructure Security Agency (CISA). The original can be found at CISA.gov.

Rockwell Automation encourages those using the affected software to implement the mitigations below to minimize risk.
Additionally, Rockwell Automation encourages users to combine risk mitigations with security best practices (also provided below) to deploy a defense-in-depth strategy.

- Disable the web server where possible (this component is an optional feature and disabling it will not disrupt the intended use of the device).
- Configure firewalls to disallow network communication through HTTP/Port 80

If applying the mitigations noted above are not possible, please see Rockwell Automation’s Knowledgebase article QA43240 Security Best Practices.

For more information, please see the industrial security advisory from Rockwell Automation.

See Also

https://www.cisa.gov/uscert/ics/advisories/icsa-22-188-01

http://www.nessus.org/u?24a0c66e

http://www.nessus.org/u?191d7a7c

Plugin Details

Severity: Medium

ID: 500693

Version: 1.6

Type: remote

Family: Tenable.ot

Published: 8/2/2022

Updated: 11/30/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2022-2179

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:rockwellautomation:micrologix_1100_firmware, cpe:/o:rockwellautomation:micrologix_1400_firmware

Required KB Items: Tenable.ot/Rockwell

Exploit Ease: No known exploits are available

Patch Publication Date: 7/20/2022

Vulnerability Publication Date: 7/20/2022

Reference Information

CVE: CVE-2022-2179

CWE: 1021