Rockwellautomation Factorytalk Use of Password Hash With Insufficient Computational Effort

critical Tenable.ot Plugin ID 500427
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In Rockwell Automation FactoryTalk Services Platform Versions 6.10.00 and 6.11.00, there is an issue with the implementation of the SHA-256 hashing algorithm with FactoryTalk Services Platform that prevents the user password from being hashed properly.

Solution

Refer to vendor advisory for Security Updates

See Also

https://us-cert.cisa.gov/ics/advisories/icsa-21-054-01

Plugin Details

Severity: Critical

ID: 500427

Version: 1.0

Type: local

Family: SCADA

Published: 8/10/2021

Updated: 8/10/2021

Risk Information

CVSS Score Source: CVE-2020-14516

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:rockwellautomation:factorytalk_services_platform:6.10.00:*:*:*:*:*:*:*, cpe:2.3:a:rockwellautomation:factorytalk_services_platform:6.11.00:*:*:*:*:*:*:*

Patch Publication Date: 3/18/2021

Vulnerability Publication Date: 3/18/2021

Reference Information

CVE: CVE-2020-14516