WordPress < 4.7.3 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9980
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote server is hosting an outdated installation of WordPress that is affected by multiple vulnerabilities.

Description

Versions of WordPress prior to 4.7.3 are affected by multiple vulnerabilities :

- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the 'wp_playlist_shortcode()' method in the '/wp-includes/media.php' script does not validate input passed via audio file metadata before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows a cross-site redirection attack. This flaw exists because the application does not validate input passed via control characters before returning it to users. This could allow a context-dependent attacker to create a specially crafted link that, if followed, would redirect a victim from the intended legitimate web site to an arbitrary web site of the attacker's choosing. Such attacks are useful as the crafted URL initially appears to be a web page of a trusted site. This could be leveraged to direct an unsuspecting user to a web page containing attacks that target client-side software such as a web browser or document rendering programs, as well as phishing attacks that mimic the legitimate site but send user-supplied information to the attacker.
- An unspecified flaw exists in the plugin deletion functionality that may allow an authenticated remote attacker to delete unintended files. No further details have been provided.
- A flaw exists that allows a XSS attack. This flaw exists because the program does not validate input to video URLs in YouTube embeds before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows a XSS attack. This flaw exists because the program does not validate input to taxonomy term names before returning it to users. This may allow a remote attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists in the Press This functionality as HTTP requests to '/wp-admin/press-this.php' do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-Site Request Forgery (CSRF / XSRF) attack causing the victim to consume excessive server resources.
- A flaw exists that allows a DOM-based XSS attack. This flaw exists because the 'renderTracks()' method in the '/wp-includes/js/mediaelement/wp-playlist.min.js' script does not validate input passed via audio file metadata before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to WordPress 4.7.3 or later.

See Also

https://wordpress.org/news/2017/03/wordpress-4-7-3-security-and-maintenance-release

Plugin Details

Severity: Medium

ID: 9980

Family: CGI

Published: 3/7/2017

Updated: 3/6/2019

Dependencies: 9035, 9036

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.1

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Patch Publication Date: 3/6/2017

Vulnerability Publication Date: 3/6/2017