Apache ActiveMQ < 5.12.0 Information Disclosure

medium Nessus Network Monitor Plugin ID 9970
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running a web application that is affected by an information disclosure attack vector.

Description

Versions of Apache ActiveMQ prior to 5.12.0 are affected by a flaw in the 'org.apache.activemq.filter.DestinationMapNode.appendMatchingValues()' function that may allow an unprivileged user to gain access to messages from a protected topic via the use of wildcards in destinations.

Solution

Upgrade to ActiveMQ 5.12.0 or later.

See Also

https://issues.apache.org/jira/browse/AMQ-3598

Plugin Details

Severity: Medium

ID: 9970

Family: CGI

Published: 2/21/2017

Updated: 3/6/2019

Dependencies: 8957

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*

Patch Publication Date: 8/14/2015

Vulnerability Publication Date: 11/15/2011