Atlassian Confluence Server 5.10.x < 5.10.6 XSS

Medium Nessus Network Monitor Plugin ID 9942


The remote Confluence server is affected by a cross-site scripting (XSS) vulnerability.


Versions of Confluence 5.10.x prior to 5.10.6 contain a flaw that allows a stored XSS attack. This flaw exists because the '/pages/doeditattachment.action' script does not validate input attachment filenames after their initial submission, e.g. via the 'newFileName' parameter. This may allow an authenticated remote attacker to edit an attachment's filename after it has been submitted to potentially execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade to Confluence 5.10.x version 5.10.6 or later.

See Also

Plugin Details

Severity: Medium

ID: 9942

Family: CGI

Published: 2017/02/08

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2016/08/04

Vulnerability Publication Date: 2017/01/03

Reference Information

CVE: CVE-2016-6283