Atlassian Confluence Server 5.10.x < 5.10.6 XSS

low Nessus Network Monitor Plugin ID 9942
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Confluence server is affected by a cross-site scripting (XSS) vulnerability.

Description

Versions of Confluence 5.10.x prior to 5.10.6 contain a flaw that allows a stored XSS attack. This flaw exists because the '/pages/doeditattachment.action' script does not validate input attachment filenames after their initial submission, e.g. via the 'newFileName' parameter. This may allow an authenticated remote attacker to edit an attachment's filename after it has been submitted to potentially execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to Confluence 5.10.x version 5.10.6 or later.

See Also

https://jira.atlassian.com/browse/CONF-43162

Plugin Details

Severity: Low

ID: 9942

Family: CGI

Published: 2/8/2017

Updated: 3/6/2019

Dependencies: 9543

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:atlassian:confluence:*:*:*:*:*:*:*:*

Patch Publication Date: 8/4/2016

Vulnerability Publication Date: 1/3/2017

Reference Information

CVE: CVE-2016-6283