Zend Framework < 2.4.11 RCE

Critical Nessus Network Monitor Plugin ID 9925

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

Versions of Zend Framework earlier than 2.4.11 are exposed to a flaw that exists in the 'Zend\Mail\Transport\Sendmai' transport in the zend-mail component that is triggered as input passed via email addresses is not properly sanitized. This may allow a remote attacker to execute arbitrary commands.

Solution

Upgrade Zend Framework to version 2.4.11 or later.

See Also

http://framework.zend.com/changelog/2.4.11

Plugin Details

Severity: Critical

ID: 9925

File Name: 9925.prm

Family: CGI

Published: 2017/01/27

Modified: 2017/01/27

Dependencies: 9135

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:thomas_breuss:zend_framework_integration_zend_framework

Patch Publication Date: 2016/12/20

Vulnerability Publication Date: 2016/12/20

Reference Information

CVE: CVE-2016-1003

BID: 95144