MantisBT 1.2.x < 1.2.20 / 1.3.x < 1.3.0-rc.2 XSS

Medium Nessus Network Monitor Plugin ID 9891


The remote web server is hosting an outdated web application that is vulnerable to an information disclosure attack reflected cross-site scripting (XSS) attack vector.


Versions of MantisBT 1.2.x prior to 1.2.20 or 1.3.x prior to 1.3.0-rc.2 are affected by a flaw that allows a XSS attack. This flaw exists because the 'manage_custom_field_edit_page.php' script does not validate input to the 'return' parameter before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade to MantisBT 1.3.0-rc.2 or later. If 1.3.x cannot be obtained, version 1.2.20 has also been patched.

See Also

Plugin Details

Severity: Medium

ID: 9891

File Name: 9891.prm

Family: CGI

Published: 2017/01/18

Modified: 2017/04/04

Dependencies: 8680

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 3.7

Temporal Score: 3.6


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mantisbt:mantisbt

Patch Publication Date: 2016/08/15

Vulnerability Publication Date: 2016/06/10

Reference Information

CVE: CVE-2016-5364

OSVDB: 139928