Atlassian Bitbucket Server 4.x < 4.12.1 XSS

Medium Nessus Network Monitor Plugin ID 9888


The remote Bitbucket server is affected by a reflected cross-site scripting (XSS) attack vector.


Versions of Bitbucket 4.x, prior to 4.12.1 contain a reflected XSS attack. This flaw exists because the pull request inbox does not validate input before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Upgrade to Bitbucket version 4.12.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 9888

File Name: 9888.prm

Family: CGI

Published: 2017/01/16

Modified: 2017/04/04

Dependencies: 9566

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 3.7

Temporal Score: 3.4


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2017/01/04

Vulnerability Publication Date: 2017/01/04

Reference Information

OSVDB: 149698