Atlassian Bitbucket Server 4.x < 4.12.0 Unauthorized Access

Medium Nessus Network Monitor Plugin ID 9887

Synopsis

The remote Bitbucket server is affected by an unauthorized access attack vector.

Description

Versions of Bitbucket 4.x, prior to 4.12.0 contain a flaw that is due to the program failing to properly enforce access permission requirements for the Default Reviewer admin page. This may allow an authenticated remote attacker to gain unauthorized access to this page, where they may e.g. add or remove default reviewers.

Solution

Upgrade to Bitbucket version 4.12.0 or later.

See Also

https://jira.atlassian.com/browse/BSERV-9392

Plugin Details

Severity: Medium

ID: 9887

Family: CGI

Published: 2017/01/16

Updated: 2019/03/06

Dependencies: 9566

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2016/12/13

Vulnerability Publication Date: 2016/12/12