Moodle 3.1.x < 3.1.2 Authentication Bypass

Low Nessus Network Monitor Plugin ID 9837

Synopsis

The remote web server is hosting a web application that is vulnerable to an authentication bypass attack vector.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 3.1.x prior to 3.1.2 are affected by a flaw that is due to the program failing to invalidate user tokens after a password change is performed. This may allow an attacker who had compromised a user's account to have their access persist after the password has been changed.

Solution

Upgrade to Moodle version 3.1.2 or later.

See Also

https://docs.moodle.org/dev/Moodle_3.1.2_release_notes

Plugin Details

Severity: Low

ID: 9837

File Name: 9837.prm

Family: CGI

Published: 2016/12/16

Modified: 2016/12/16

Dependencies: 9398

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2016/09/12

Vulnerability Publication Date: 2016/09/12

Reference Information

CVE: CVE-2016-7038

BID: 93174