Moodle 2.9.x < 2.9.9 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9834


The remote web server is hosting a web application that is vulnerable to multiple attack vectors.


The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.9.x prior to 2.9.9 are affected by mutliple vulnerabilities :

- A flaw exists when debugging is enabled that is triggered as error exceptions from web services may return too much information. This may allow a remote attacker to potentially disclose private data.
- A flaw exists in the question engine that may allow an authenticated remote attacker to download files embedded in questions from the system by guessing the URL of the file downloading it using the identifier of a question they are authorized to access.
- A flaw exists in an unspecified web service that may allow a non-administrative remote attacker to make changes to administrative information for other users.
- A flaw exists that is due to the program failing to properly perform capability checks on users who have site-wide permissions which were revoked within a specific course. This may allow an authenticated remote attacker to disclose course note information.


Upgrade to Moodle version 2.9.9 or later.

See Also

Plugin Details

Severity: Medium

ID: 9834

Family: CGI

Published: 12/16/2016

Updated: 3/6/2019

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*

Patch Publication Date: 11/21/2016

Vulnerability Publication Date: 11/21/2016

Reference Information

CVE: CVE-2016-8642, CVE-2016-8643, CVE-2016-8644

BID: 94441, 94457, 94458