Moodle 2.9.x < 2.9.8 Authentication Bypass

low Nessus Network Monitor Plugin ID 9833

Synopsis

The remote web server is hosting a web application that is vulnerable to an authentication bypass attack vector.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.9.x prior to 2.9.8 are affected by a flaw that is due to the program failing to invalidate user tokens after a password change is performed. This may allow an attacker who had compromised a user's account to have their access persist after the password has been changed.

Solution

Upgrade to Moodle version 2.9.8 or later.

See Also

https://docs.moodle.org/dev/Moodle_2.9.8_release_notes

Plugin Details

Severity: Low

ID: 9833

Family: CGI

Published: 12/16/2016

Updated: 3/6/2019

Dependencies: 8690

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 3.7

Temporal Score: 3.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*

Patch Publication Date: 9/12/2016

Vulnerability Publication Date: 9/12/2016

Reference Information

CVE: CVE-2016-7038

BID: 93174