Atlassian Crucible Server 3.10.x < 3.10.3 XSS

Medium Nessus Network Monitor Plugin ID 9784

Synopsis

The remote Crucible server is affected by a Cross-Site Scripting (XSS) attack vector.

Description

Versions of Crucible 3.10.x prior to 3.10.3 are affected by a flaw that allows a XSS attack. This flaw exists because the program does not validate input to profile settings before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to Crucible version 3.10.3 or later.

See Also

https://jira.atlassian.com/browse/CRUC-7593

Plugin Details

Severity: Medium

ID: 9784

Family: CGI

Published: 2016/11/18

Updated: 2019/03/06

Dependencies: 9571

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:crucible

Patch Publication Date: 2016/02/09

Vulnerability Publication Date: 2016/02/09