MyBB < 1.8.8 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9777

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

Versions of MyBB (MyBulletinBoard) prior to 1.8.8 are affected by the following vulnerabilities :

- An unspecified flaw may allow a remote attacker to overwrite style import CSS. No further details have been provided.
- A flaw exists that may allow carrying out a SQL injection attack. The issue is due to the users data handler not properly sanitizing input before using it in SQL queries. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.
- A flaw exists related to request handling between a user and a server, where the server can be induced into performing unintended actions (Server Side Request Forgery aka SSRF). By making a crafted request to the 'fetch_remote_file()' function, the server can be used to conduct host-based attacks. This may allow an attacker to bypass access restrictions (e.g. host or network ACLs), conduct port scanning of internal networks, enumerate internal hosts, or possibly invoke additional protocols (e.g. Gopher, TFTP) which may give additional control over such requests.
- An unspecified flaw may allow a remote attacker to gain short name access to ACP backups on Windows servers. No further details have been provided.
- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the ACP does not validate input before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- An unspecified flaw exists related to loose comparisons that may result in false positives. No further details have been provided.
- A flaw exists that allows a XSS attack. This flaw exists because the ACP user module does not validate input before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to MyBB version 1.8.8 or later.

See Also

https://github.com/mybb/docs.mybb.com/blob/gh-pages/versions/1.8.8.md

Plugin Details

Severity: High

ID: 9777

Family: CGI

Published: 2016/11/11

Updated: 2019/03/06

Dependencies: 9126

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2016/10/17

Vulnerability Publication Date: 2016/10/17