Atlassian JIRA 7.1.x < 7.1.7 XSS

Medium Nessus Network Monitor Plugin ID 9739


The remote web server hosts an application that is vulnerable to stored cross-site scripting (XSS) attack vector.


The version of JIRA installed on the remote host is earlier than 7.1.7 and is affected by a flaw that allows a stored XSS attack. This flaw exists because the 'ViewWorkflowTransition.jsp' script does not validate input when handling usernames before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.


Update to JIRA 7.1.x version 7.1.7 or later.

See Also

Plugin Details

Severity: Medium

ID: 9739

File Name: 9739.prm

Family: CGI

Published: 2016/11/04

Modified: 2016/11/23

Dependencies: 9541

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 4.2

Temporal Score: 4


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:jira

Patch Publication Date: 2016/05/18

Vulnerability Publication Date: 2016/05/18

Reference Information

OSVDB: 145401