Drupal 7.x < 7.34 DoS

Medium Nessus Network Monitor Plugin ID 9728

Synopsis

The remote server is hosting an outdated installation of Drupal that is vulnerable to a Denial of Service (DoS) attack vector.

Description

The version of Drupal installed on the remote server is 7.x prior to 7.34, and is affected by a flaw in the password hashing API. It is triggered when handling a specially crafted request, which can cause a consumption of CPU and memory resources. This may allow a remote attacker to cause a denial of service.

Solution

Upgrade to Drupal 7.34 or later.

See Also

https://www.drupal.org/SA-CORE-2014-006

Plugin Details

Severity: Medium

ID: 9728

Family: CGI

Published: 2016/10/28

Updated: 2019/03/06

Dependencies: 9211

Nessus ID: 79362, 79386, 79677, 79679, 79775, 82456

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2014/11/19

Vulnerability Publication Date: 2014/11/19

Reference Information

CVE: CVE-2014-9016

BID: 71202