Magento Community Edition 2.x < 2.0.4 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9693

Synopsis

The remote web server is running an outdated instance of Magento Community Edition (CE) that is affected by multiple attack vectors.

Description

Versions of Magento CE 2.x prior to 2.0.4 are affected by multiple vulnerabilities :

- A flaw exists that allows a stored cross-site scripting (XSS) attack. This flaw exists because the program does not validate input to the username field when registering storefront customers before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that allows multiple reflected XSS attacks. This flaw exists because the Authorize.net payment module does not validate input before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists that is triggered during the handling of a specially crafted language package. This may allow a context-dependent attacker to potentially execute arbitrary code.
- A flaw exists in the Admin and Customer Token APIs that is triggered as limits are not set for password guesses. This may allow a remote attacker to conduct a brute-force attack.
- A flaw exists in the Web API that is triggered as it allows anonymous access. This may allow a remote attacker to gain access to potentially sensitive information regarding a merchant's products, promotions, and storefronts.
- A flaw exists that is due to the program generating weak encryption keys in the 'System > Manage Encryption Key' page. This may allow a remote attacker to more easily gain access to encrypted content.

Solution

Upgrade to Magento CE version 2.0.4 or later.

See Also

https://magento.com/security/patches/magento-204-security-update

Plugin Details

Severity: Medium

ID: 9693

Family: CGI

Published: 2016/10/17

Updated: 2019/03/06

Dependencies: 9691

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:magento:magento

Patch Publication Date: 2012/03/31

Vulnerability Publication Date: 2012/03/31