Atlassian Confluence Server 5.9.x < 5.9.11 XSS

Medium Nessus Network Monitor Plugin ID 9648

Synopsis

The remote Confluence server is affected by a cross-site scripting (XSS) vulnerability.

Description

Versions of Confluence 5.9.x prior to 5.9.11 are affected by a flaw that allows a stored XSS attack. This flaw exists because the 'viewmyprofile.action' script does not validate data before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to Confluence 5.9.x version 5.9.11 or later.

See Also

https://jira.atlassian.com/browse/CONF-42713

Plugin Details

Severity: Medium

ID: 9648

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2016/05/27

Vulnerability Publication Date: 2016/05/27

Reference Information

CVE: CVE-2016-4317