Atlassian Confluence Server 5.8.x < 5.8.17 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9647


The remote Confluence server is affected by multiple vulnerabilities.


Versions of Confluence 5.8.x prior to 5.8.17 are affected by multiple vulnerabilities :

- A flaw exists that allows a reflected cross-site scripting (XSS) attack. This flaw exists because the '/rest/prototype/1/session/check/something' script does not validate input passed via the URL before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- An insecure direct object reference flaw exists in the '/viewdefaultdecorator.action' script that is triggered when it does not properly restrict requests for files passed via the 'decoratorName' parameter. This may allow an authenticated remote attacker to gain access to read configuration files.


Upgrade to Confluence 5.8.x version 5.8.17 or later.

See Also

Plugin Details

Severity: Medium

ID: 9647

Family: CGI

Published: 2016/10/14

Updated: 2019/03/06

Dependencies: 9543

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2015/11/16

Vulnerability Publication Date: 2016/01/04

Reference Information

CVE: CVE-2015-8398, CVE-2015-8399

BID: 79818, 79819